Machine freezing once torch is plugged in

Having some issues…
I programmed a small 1" by 1" square so that I could test cutting speeds and offsets and loaded the G code into Mach3. With the torch fire unplugged from the langmuir box, I hit cycle start and it appeared to work fine. Then I did nothing but connect the torch and hit Cycle Start, it fired the torch, then wouldn’t move (and of course it was stopped right on top of a slat… burned 3/4 of the way through it.) I couldn’t even get the torch to turn off from the control, I had to unplug the torch. Tried a different program, same result. When it hangs up, it will say “RnR motion card not found!” in the Mach3 status bar and nothing will work until I unplug the USB and plug it back in again… any ideas? If I could attach videos I would

What plasma cutter are you using? I.e. it is not HF start correct?

Chicago electric 40a pn 95136

My very first cut did this but it actually was my computer that did the not responding thing I also had to pull the torch fire plug. Never done it since.

Yeah I tried probably 10 times and it was still doing it. Ill uninstall everything and retry again tonight if one of the Langmuir guys doesn’t have a better idea

We spoke to Austin this morning and are working with him to find a root cause to this issue. Once the solution has been reached, we will post it here. Thanks.


That’s excellent. One thing that some companies do that drives me nuts is using a forum for problem reporting by customers but not posting the solution on the forum in return - they move it offline 1 on 1 with the customer. That leaves everyone else wondering what the issue & the fix was. Posting the solution closes the loop and helps let everyone else should the problem arise for anyone else in the future. Kudos!


I’m having the same issue. The torch will fire but will not move. I tried to manually cut a straight line but the arrow keys were not responsive. If i turn off the plasma cutter and them use the torch on/off command in Mach 3 the arrow keys allow me to jog the machine. Once I turn on the plasma cutter and use the torch on/off command in March 3 the torch lights but no movement of the gantry happens. I’m using a Lotos 60 non HF start cutter.

What is the model of your plasma cutter?

I have a Lotos Supreme CUT60D. It has a CNC port and a non-HF blowback arc start torch.

Does it only happen when you try to jog for manual cutting? Or does it also happen when you try to run a program?

I did not try to run a program on it after it failed the manual test. I did not have a program to run at the time I was testing. I will try to complete a sketch in Fusion 360 and run it on Tuesday.

Same problem here. I cut several parts today with no trouble. I tried to make a manual cut to trim my sheet metal and Mach3 froze with the torch engaged, no movement on the axis. If I unplug the torch wire from the control box, the machine will make a flawless dry run. Or if I power down the plasma and leave the trigger wire plugged in it will also make a good dry run. It will not cut in automatic nor manual at this point. My cutter is a Thermal Dynamics 60i.

Same issue here. Runnning it with a lotos cut60d, microsoft surface running on battery.

I updated another thread, but here is what worked for me:
Cut parts! So after checking everything, trying a different laptop (also running off battery) I moved the laptop off the surface of the steel welding table to an amazon box giving it approx 8-10 inches of clearance. When i did this i also had to reroute the torch firing wire, but it performed great on both laptops once this was complete.


I am also dealing with this issue. Was quite discouraging running into this issue after the wait, time of assembly, time of programming and even the smooth break-in process… First cut moved the gantry to the first cut, turned the torch on, then just sits there and freezes until i manually turn everything off.

Any help to resolve this would be great! Thanks in advance.

@canden007 Hi Canden, sorry to hear about your issue. Which plasma cutter are you using with the CrossFire?

Lotos CT520D

Thanks for the quick reply!

Unfortunately that is high frequency start plasma cutter and it not on our list of compatible units. The high frequency is whats causing the problem.

1 Like

Just now seeing the “Plasma Cutter Notice” on your page. I guess I will be investing in a better plasma cutter! Just didn’t see that when I purchased. I’m hoping no damage has been done already…