Mach3 not seeing tap file only dxf

I am using Mach3 and sheetcam. I have successfully cut several pieces, but I downloaded some files from fireshare, unzipped,& open in sheetcam, I can find them in saved files but cannot find through Mach 3 in my g code file. If I open in Mach there is no code to be processed. Any help would be greatly appreciated.

I’m assuming the files you downloaded from Fireshare were in fact dxf? Did you post-process these dxf files in sheetcam to produce the tap file? …only after post-processing the dxf file can you produce gcode (.tap file)

1 Like

Yes I did download dxf file and was able to create tap file in my g code but after opening Mach 3 to search for file it’s not there. It’s like Mach 3 doesn’t recognize. In sheetcam what is the post processor set to. I have mine on Mach 3 noZ

Mach 3 No Z should be fine. Was the resulting tap file maybe saved in some other folder? Can you locate the tap file using explorer?

I found g code in separate file but when I try and open it in Mach 3 it’s not a full file or it’s corrupted. It’s not giving me a picture preview. The file is much shorter than previous downloaded art. What am I doing wrong?

Let’s get more info… Which dxf file did you download from FireShare?
Maybe you want to try downloading it and post processing it again and save the resulting .tap file as a different name from your last?
Here is a simple AutoCAD dxf file (3" square with 1.5" hole). Try downloading and post-processing that and see what happens?

Simple Square with Hole.dxf (28.9 KB)

1 Like

I have tried to re-download art, re-import it to sheetcam and then run the post processor. It saves the g code but the file is always 200-400 bytes. It’s not complete. I feel there’s a disconnect with the post processor in sheetcam. I’ll try yours now

I tried the simple square dxf - the g code is 201 bytes and will not cut on the cnc

did you purchase a license for sheetcam AND mach3? both need full licenses to use full gcode.

i’m thinking you’re running the demo versions of either one or both. that’s why you’re only seeing a partial of the gcode.

1 Like

I have purchased both

open the .tap file and see if it shows anything in it

all of the tap files I have created today are empty for the most part. Maybe 400 bytes. All my others are different amounts of KB. When I open them in Mach 3 there are maybe 6-9 lines of code versus my others that are tons of line of code

ok so it seems theres an issue with sheetcam then if it’s not supplying the full gcode.

for shits and giggles, go to help and then about and see if yours is still registered

1 Like

So you’re saying Mach 3 is working fine otherwise with the other files you have, that are “tons of line of code”?

This is a previous download

THis is the simple square. Thats all the code that came thru

hehehehe, you beat me to it. :nerd_face:

1 Like

Yes. All of my other files open and cut from Mach 3. Anything new will not send the whole g code

I did and it is.

Hmmmmm, Reinstall and re-register SheetCam maybe?