Mac not connecting to Pro Break In Program

We have the Cross Fire Pro with the RW45, and Torch Control. We installed Adobe Illustrator and got it working. We downloaded Fusion 360 and it is up and running. We got fire control up and running. We have a 2021 MacBook Air that is a 64 bit computer. When I attach the USB cable I have connection to the machine and the Torch Height Control. I can move all axis points. We are really anxious to get this machine up and running. We are just using the machine to create vector cuts for signs. We cannot get the Break In Program to run. It downloads and when we click the file it states it cannot find the app to open it. We tried to put the file on our desktop and click run. It states it cannot run the file. I know the Apple has an M1 chip. I don’t know if this is a problem.

We tried to got to Langmuir projects page. We grabbed two files with g-codes on them. We could not get them to open in Fire Control. It had the two G-code files and SVG and PNG file.

Yes, I did go through the forum and try to find reasons for my failures. I did find answers to other problems we were experiencing.

To run a program in Firecontrol, you have to open the program with it connected to the machine and click on the arrow in the “load program” field. Navigate to the folder that your file is in and select the file. The file will load and show in the visualizer. Firecontrol will only run files with a .nc or .tap file extension that were post processed with the Langmuir post processor.

1 Like

I believe the issue we are having is that Fusion360 will not open the post processing file. It gives us an error message stating that it doesn’t recognize the file type.
Screen Shot 2021-11-22 at 6.23.17 PM

Is this also why we aren’t able to locate our machine in the machine & post dialogue box?

Thanks for your help!

We have dealt with several issues getting our machine set up and running. We have had the machine for nearly two months and have not been able to get it running/cutting anything yet. Finally was able to run breakin program today. Not sure what to do with it now.

Current issues are:

  1. Fusion 360 doesn’t recognize machine.
  2. Trouble running post processing download.
  3. Not sure what settings to use when we finally do get it up and going.

All we want to do is cut sheet metal for art/signs. We are not machinists by any means, so this is all very foreign territory and we were expecting a big learning curve, but we’re getting quite frustrated. Please help!!

Are you still looking for help?
I see your machine now up for sale within an hour of this post.

these are the same issue . you do not running your post processor, you install it.
this has a video on how to install your post processor

There is a lot to it . It is the trade off for buying an inexpensive kit machine.
But one small step at a time and you will be able to make this work.

“there is only one way to eat an elephant : a bit at a time” tutu

1 Like

Please take a look at this link for a description of the workflow you will need to follow. There are links to the tutorials for installing post processors.

You may also want to check out the Video Overview of FireControl:

1 Like

We REALLY appreciate everyone’s responses in an attempt to help us work through some of the issues we’ve been having with getting our machine up and going. You have all been very helpful and encouraging - and after giving it some time, we have decided to try and make this work, but we could use some more suggestions…

We have gotten the machine to the point where we are trying to make our first cuts, but the torch will not fire. We are trying to do the test in fire control and we see no arc.

The torch is responding and moving in all directions, and even follows the g-code that we chose from the share site (Thank you for your help on that too!)…but it does not fire. We’ve read through the comments on the forum, and it looks like this is a common problem, but each of the suggested “fixes” doesn’t seem to make a difference. We hear an audible “click” when the torch is enabled, but nothing else.

Any ideas would be appreciated! (Again, thank you all!)

When you hear the click, do you hear air flowing from the torch?

If not, pull the trigger on the torch(if you have a hand torch) and see if it fires.

If it fires, you don’t have the torch firing wire connected properly between the plasma and the control box.

If it doesn’t fire, make sure you have your air pressure set high enough. You need at least 60-65psi on the machine.

If the air pressure is good, take the cap off the torch and make sure the electrode moves up and down freely.

1 Like

When we hear the click, we do not hear air flowing from the torch.

When we pull the trigger on the torch, it does fire, and we do have air flowing through the torch for about about 30 seconds, and then it shuts off.

This is how the connections are right now.

OK. You have an open port on the front of the plasma. There should be a wire going from that to the control box on the leg of the table where it says “torch on/off”.

Its a guessing game with the Razorweld machines as to which port is the torch firing port, but its easy to figure it out. Plug in a wire between the open port and the torch on/off port on the control box and try to fire the torch with the manual fire button in Firecontrol. If it doesn’t fire, switch the cable to the other port on the front of the plasma and try again. If it fires, then that port is for torch firing and the other port should have a wire going to the DIV input on the little plastic box.

1 Like

We finally did it! Thank you all for your amazing help!! We couldn’t have done it without your direction and help! Here is our first cut :smile:


I just seen this post, how the heck did you get your Mac to run the programs? I bought a Mac book air 2021 when I ordered my table and it will not run them all! I was told it’s to new!
So spent another 2 k on a dell! I hate a windows pc! :joy:

Honestly, we must have gotten lucky, we followed the guidance we’ve read on this forum from a lot of people, and we also watched a lot of youTube videos. We actually went and bought a $1500 PC in the hopes that it would help resolve some of the issues we were having, but we were still running into issues, so we decided to plow ahead with the Mac, and return the PC. Somehow the stars aligned, and it worked. If there’s anything we’ve done, it’s that we’re using Adobe Illustrator to prepare our files as SVG’s to import to Fusion 360 to create the g-code. There’s some really helpful videos on how to do all that, that we found on YouTube. If you’re still interested in trying to make it work, we’d be happy to talk to you directly.

Check these out on YouTube (AM Custom Fab - He has a Langmuir Pro video about how to turn images into g-code using Fusion 360) and (Design Made Simple - He has a great video about how to prepare a PNG file to a Vector with Adobe Illustrator).

Sorry for the late response - hope that is helpful.