Loosing Steps While Cutting Large Signs

So I’m running into an issue with my machine losing steps.

It only seems to happen on bigger things. I have now scrapped 2 sheets trying to cut this sign for a customer.

14 GA 200inches per minute using a hypertherm 45xp and fine cut consumables

I am using Fusion360 for the CAM processor

See the photos

Can someone help me, the tables on a few months old with a total cut time of 2 hours on it

tighten all the couplers. use a metric allen key.

1 Like

I have confirmed all the coupler screws are nice & tight

try connecting a sharpie and doing a dry run on cardboard or metal to see where your problems might be. if the couplers aren’t slipping then it could be binding somewhere.


Also wd40 or a light weight oil on the lead screws. That is if couplings not slipping.

1 Like

I have tried using the WD40 silicone dry lube on the lead screws

Can you do a dry run watch for binding?? The couplings are also easy to strip. Also hard to catch if you don’t mark them.

May even double check step motor plugs for a good connection.

Do dry runs till you figure out what’s up . Go to a scrap piece of material fire the torch to make a pierce hole zero out . Jog around the table return to zero fire the torch to see how far off you are and which direction.

1 Like

I put on some torque seal on the couplers, I’ll wait for it to set up overnight and I’ll do a bunch of dry runs with a sharpie

Once this is complete, I’ll report back.

Thank you everyone :slight_smile:


If they are slipping save yourself some headache order better ones.

So did a dry run of the crossfire pro break in program & there didn’t seem to be any issues

I ran a dry run of the sign and the machine appears to be binding, however, I haven’t been able to identify on which axis. Based on the issues with my cuts I would have to say the x axis.

I am unable to replicate binding using jogging alone even at 300ipm

The good news is that I do not appear to have issues with my couplings.

I guess I’m going to verify the machine is still square, however, I would imagine that would not be the issue for the X axis.

I think I’ll remove the torch from the machine and test again to see if there’s too much drag to something from the cable hanger.

Thank you


So you said it only did on large signs? How new is your machine?

Is it possible that you have one of the bearing blocks for the lead screw switched? It could cause binding when goin to the extremes.

So I removed the torch from the machine…

disconnected both Y motors tested & the x axis binds…

reconnected both Y motors and disconnected X and tested, Y axis binds…

My machine was ordered in Sept 2022 & assembled in Nov 2022. I have mostly been cutting with the standard consumables at 48-129ipm I work mostly with 1/8 & thicker.

I never had any issues until I started pushing the machine faster for the fun cut consumables & thinner sheets… although I have cut a few small signs at 225ipm & standard consumables previously with out issue.

I’m gonna try to re-square my machine now

1 Like

Good call.

If it’s the X axis, check the two bolts that hold the lead nut bracket. If they are loose, you will lose motion on X direction changes. It could also cause binding, because the lead nut is not aligned with the screw

1 Like

So I have verified the following:

  • squareness of my machine
  • lead nut brackets are still tight
  • couplers are tight, marked, & verified they are not slipping.
  • lubricated lead nuts with dry silicone spray
  • verified that y axis is even on both sides
  • used a dial indicator to verify repeatability

Also, note that I can not get the machine to lose steps no matter how much I jog the machine around at 300ipm. It only jams up while running a program.

@langmuir-reilly @langmuir-daniel @langmuir-mike do you guys have any ideas?

Here is a copy of my G code, just in case there’s an error. I’m using fusion360 to generate the came & post process. Newport Helicopter Tours 14GA FINE CUT.nc (297.6 KB)

Thank you again everyone for your time & help.

I don’t know if this is of any value, but jogging at high speed is not likely to show up the imperfections of movement. I would suggest jogging at no faster than 50 ipm and for the z axis, really slow. You are looking for any inconsistencies.

Agreed with you asking for more help from langmuir.

Certainly could be some electronic interference. That is a chapter I have not had experience with.