Limit Switch Homing Issues

X- axis homes and backs off fine, but the Y-axis homes but doesn’t back off the limit switch throwing an alarm. Also the machine zeros aren’t on zero when its home ( not really homed I guess due to alarm being in) Any help, ideas, or anybody else have this problem. Its on a Cross fire Pro. Thanks

1 Like

Did you reset the machine defaults in firecontrol?

Yes. Fire control has been reset

But I’m going to try it again… Maybe I’m overlooking something… Thanks…

What you are describing sounds like what others have reported. Make sure you update firecontrol, the machine firmware, and reset the defaults.

I think when I did mine I had to jog around a bit and hit home a few times before it settled into the same spot each time. I had to clear several error alarms to get it where I wanted it before I set home and set the soft limits.

1 Like

Hey Travis,

I was having similar problems.

All of my FW was updated, and I was able to set machine zeros correctly with the limit switches stopping the motion as intended. However, when I went to jog away from those switch positions I’d immediately get an alarm that the machine was outside of limits… got the same error for both X and Y axis.

I had not set the soft limits yet so those values were still at 0.00" each. After some fussing around I was able to get the machine off the limit switches and manually jogged it out to the limits of X and Y and typed those numbers into the Soft Limits area. Once that was completed and saved, I did not have any more issues.

My theory is that the FW is reacting to the soft limits being at 0.00" and assuming that anything above that value is beyond the travel limits of the machine… which then keeps throwing those error messages? Once you have larger, correct values set for your soft limits you should be able to jog normally away from the machine home position. At least that seems to be working for me today.



Hey all,

I followed everyone’s comments here and i have double checked all the wiring, my software is at the required levels reset the machine and I am confused my Z homes away from the limit switch? Any thoughts from anyone?

Corrected my issue.

mind sharing what you found and did…

Your Z should go up and down… Not to or from an x or y limit.

What corrected your issue? My limit switches haven’t worked yet. Y-axis will not back off switch once homed throwing an alarm.

Have you set your soft limits yet? Is it possible your soft limits are preventing it to move? Take a screenshot of that maybe someone will see the issue.

Yeah was a simple fix, I had the Y axis stepper motor at the wrong end of the Y gantry which caused the Y to move away from the limit switch. Simply put my Y axis + and - travel was reversed. Once I reversed the lead screw and Y stepper motor by installing the stepper motor over the electronic enclosure, it worked as designed. Was my mistake duh!



Scott, mistyped I meant to type Y, just needed some sleep :slight_smile:

1 Like

thanks for the reply…and glad you got it…

I know you said you reset Firecontrol but this might be worth a try:
Provided by @ds690
There was some discussion in another thread about problems with a limit alarm when the torch fired. Langmuir made some changes to the firmware to fix the issue. The firmware number didn’t change, but you should re install the 1.3 firmware to get the updated version.

This turned out to fix most of my issues with the limit switches.

1 Like

Had to jump on the forum to troubleshoot this issue an hour ago. Search function worked and I found your post. I was getting the alarm on torch firing.

Updated the firmware again and back in business.