IHS fail on my new XR

I am trying my first cut. Simple part 4"x 4" square with 5 holes. Have a program with G codes in Fusion 360 and Sheet cam. Does not matter which program you run same result. The Z axis comes down and when it makes contact with the steel it acts like it just keeps pushing on it hard. The first time it cut two of the holes moved to the third hole before I got a Machine fail IHS Fail. The next time it just came down it seem to just keep pushing on the metal and then machine fail. Next time it cut one hole moved to the second hole and machine fail. So, I clear everything and try again. I am going to try to send the Machine alarms and program error in the order I get them before I clear them. Also, that little wireless keypad they sent does not work 95% of the time and the little hard drive won’t read a SD card for my downloads have to use a thumb drive. HELP!!!

call Langmuir first thing in the morning…you have something not making contact with the THC system

1 Like

They didn’t send in order. 1st Machine alarms IHS Fail. Next The Program error happened on line 31. Next Machine alarm reset. Last one Program error happened line 32.

I’m not sure if the XR uses the same IHS switch as the pro, but this indicates a failure with the switch or an unhooked IHS wire.

If a wire was not hooked up, it should throw an error immediately and not try to probe the torch downward. I would suspect that something is wrong with the IHS switch mounting.

The IHS commands in the code tell the Z axis to move down up to 5 inches or until the IHS switch opens. If it’s trying to keep going down after hitting the metal, the switch isn’t opening. I would check to make sure that both sides of the switch are screwed into the Z axis.

1 Like

Check wires to IHS switch and where plugs into fire control controller.
Remove Zaxis cover and look at IHS switch contacts to make sure not pushed into threads of the Z axis screw, (mine was when shipped).
Does the IHS on monitor turn green when you manually push torch up by hand? You have the right post processor selected.?

I share my tap files to OneDrive from my laptop to mini pc on my XR table.

The IHS on the monitor only turns green when it makes contact with the part. I emailed Langmuir if I need a program like Norton on the monitor that came with the XR. He said no but to run fire control with my internet turned off. I don’t use OneDrive because my internet is spotty at best.

1 Like

Yes, will turn green when torch touches material, then it will go to pierce height light will be off. Your IHS switch is working, have you removed Zaxis cover and inspect IHS is not pushed into lead screw on z axis.?
I run my XR with Wi-Fi on no issues with my machine doing goofy stuff.

Yes I looked at the IHS switch looked fine. I will look tonight and see about that pierce height light.is doing. Thanks

Ok Rat don’t hate me. When I got home I looked at the IHS again where you told me. It was or is touching the threads. I pushed it away some fired it up and it ran. I don’t know how close it is suppose to be or even touching it. Does this look OK. I ran 6 parts and had no problem. Thanks for your help. Hope I can call on you again some time for help.


I would not think it should be touching at all. Looks like it needs to be squeezed together right where its touching the threads to me

1 Like

I’m with you on that. Looks like it should be pushed away from the threads. I don’t want to push too hard and brake something.

That piece looks to be copper so it should push away pretty easy with a screw driver

1 Like

That copper piece is stuck that 3/16 or 1/4 arm.

bend that arm away from that screw so the copper doesn’t touch it.

Interesting to see the new IHS style

You don’t want that touching z axis screw at all. Bend it out from screw be gentle.