First FireControl update posted

The next time you load FireControl you will see a green update button in the top left corner of the interface. You’ll want to update to the next version of software which is 20.2.

In this version we addressed a number of issues primarily related to reducing processor and memory overhead while also addressing some intermittent bugs that related to the way G code is processed. We also made enhancements that allow the visualizer to run much smoother.

We plan on making frequent updates to FireControl including ones that add new features. For example, we already have scale and rotate working in an unreleased version that we are testing and will at some point will tie into a future release. For now our primary objectivity is stability. Any time you see the green update button we strongly encourage you to update.

As always we welcome feedback. If you see bugs, report them! If you have ideas for new features, share them! Thanks to all.


I click on the on the green update bottom but gave me 20.1.msi version

but if I go straight to the download page I get 20.2

that’s a bug or I’m doing something wrong?

Same issue here…I get 20.1 when clicking update button in firecontrol.

One of the software engineers is looking into this but the 20.2 version on the website is DEFINITELY what you want to install. Sorry for the hiccup.


All I am seeing is that the software is pending for Mac. Just got a new MacBook Pro. Is there a way to download original version?

Hi Nick,

You can download the FireControl 20.2 Mac installer below. We are having some small stability issues with it but it may work fine for you. We are going to be working on a stable Mac release this week but you might find no issues with this version. Please let us know any feedback if you can!

If you have Parallels, FC 20.2 works great through it’s emulation. FC 20.1 didn’t show the tool path in the browser under emulation but it does now. I had a THC issue on the Mac version which made me try the emulator (which is when I noticed the lack of toolpath drawing).

I’ve had plenty of successful runs on the Mac version but until we pinpoint that THC bug, I’ll run 20.2 in Parallels for jobs and the Mac version for my own stuff.

1 Like

I was using my old MacbookPro for my first 2 days. I received my new MacBook Pro in the mail the night before I came to work. My THC arrives today so I will be installing it tomorrow and seeing how everything runs on the new MacBook. Did not have any problems with my last Mac but I did not have the THC installed yet.

The THC with Mac will work for most cuts there are just a few edgecase bugs that we are working on. Please try the new 20.2 Mac installer that I linked above and if you get any reproducible issues please let us know so that we can fix them for the next Mac release!

Thanks for mentioning that it was an update Mike, I had not noticed till you did.

1 Like

I installed my THC this morning and am having 2 issues with Mac version. First is that after I hit the start button to cut the file it will cut the first piece and when it goes to cut the next piece the torch tries to fire, will fire momentarily and then I get the message. “Arc Voltage was lost during cutting program. The program has been paused and the machine location saved…”. When I click run from here and start it will do the same thing. Cut the first part then on the next one it won’t fire and I get the same message. I did get it to work without error message by hitting pause until hypertherm 45xp finished its 10 second blowout. When I would hit start again it would cut the next part without error message but I would have to pause it when it finished that cut.

Second problem nothing shows up in the THC box in FireControl. The red light on the THC controller is on. But the active, up, down, has yet to show up on FireControl. I tried to cut a piece of warped stainless and it worked on one cut. I was using the straight cut function. Second cut 1/8 of an inch above that cut the torch crashed into the stainless and stalled.

Hi Nick,

It would help us greatly if you are able to capture a video of what you are experiencing both in FireControl and at the machine cutting. If you can send us the video to it would be a huge help. We are working on a stable MAC release this week and your input will help us a lot. The good news is your issue is nothing hardware related; it appears to be an issue in FireControl with Mac that we are working on and should fix soon.


I am going to try with my PC shortly.

Hey Nick,
On Mac as well, I ran into this too. Are you using “Lead outs” in your program? I was and Daniel advised that Lead Outs are typically no bueno when using THC. I ditched Lead Outs and haven’t seen the issue again.

Also, the other issue I did see initially was, when cutting 16g running SMART voltage in THC, my plasma head was diving into the material, even into the water table itself once as it moved the material… by turning off SMART and running the manual voltage as indicated by the Hypertherm cut chart, the THC has been behaving properly and the issue has not returned.

I’m sticking with manual THC voltage settings until I hear otherwise from LS.

I’m heading home shortly and will try this out. Thank you. I am looking at the cut chart. What setting do you put in for 16g stainless?

Do you use sheetcam or fusion?

I use Fusion and set the THC voltage to 128.