Firecontrol Freezing

Having problems with firecontrol freezing, been an issue for a few months but feels like its gotten worse with the latest update. Looking for ideas from others as to what they’ve done to solve their issues. I am using a desktop windows PC. Newest version of firecontrol, newest firmware for both THC and height control.

When it freezes, the torch stops while still firing. I have had it freeze and go “not responding” as well as had it semi freeze, where the torch stops and continues to fire but I can still interact with firecontrol in a limited fashion. I cannot reset or stop the program, but can fiddle with the THC buttons and feedrate buttons.

I have had it happen during a dry run as well.

I have also heard the USB unplugged noise from my computer speakers only sometimes when the issue happens, however checking the device manager I can still see the THC and control board connected in my devices.

Things I have tried so far starting from the PC:

Tried different USB plugs
Installed a USB isolator
Replaced USB Cable
Attempted to route cables as far away from one another as possible
Attempted to tape the USB cable as to limit any movement at its connection
Replaced the MCB in the controller.
Moved the plasma cutter as far away as I could from the machine

Anyone have any other ideas before I buy a new PC to test?