Firecontrol Freezing with choke ***SOLVED***

First off I am a brand new to having a plasma table and am still learning the whole process, I just received my Crossfire Pro last week and got it assembled. I made a simple 3" x 3" square piece on fusion 360 with 1/4", 1/2", 3/4" and 1" hole in the 4 corners, I wanted to measure them to see how accurate it was, and not just cut out a square, I ran the program with a torch off because I am testing on scrap pieces and wanted to make sure it would fit in the area provided. With the torch off the program ran fine, no issues. Once I turned on the torch and ran the program it would cut the first hole then freeze, the torch pulls off the plate like its going to move to the next hole but then FireControl freezes and I can’t stop the program or pause or anything, I had to exit out of the program. I tried it multiple times and each time it would freeze up. I have the choke they sent on the usb cable and I am using the Razorweld 45, my computer is a few years old, I didn’t know if that might be the issue, it has the specs to run the program, I didn’t know if anyone had any suggestions or tips to try, thanks in advance!!!

Side note, I also tried just some straight cuts with the tab in fire control, it would cut just fine but freeze at the end of the cut and would not end the program, I had to exit out of FireControl again

Some customers need more than one choke, we will send to you ASAP.

1 Like

You sent me 2 chokes with my cables, I will try adding the second one on it tonight and see if that fixes the issue. Thanks Daniel!

YOUR THE MAN DANIEL! Added the second choke and everything ran smooth! I appreciate the help! Cheers!

1 Like

That’s great! You’re about to be the proud owner of two more chokes because they went out today LOL.

1 Like

Haha, Well next person to have the same issue who doesn’t have chokes to use I will pass on the gift to them!!!