FireControl 20.6 Freezing after Cut Complete

Recently received my table. Got everything together and calibrated. Everything works, but Firecontol freezes when it is done cutting. Pop-up appears saying program complete, and it will let me close that pop-up, but completely locked-up after that. I close Firecontrol and start it again and everything fine until I cut again. It does a Dry Run just fine, no issues. I’m wondering if it is THC related since the THC is disabled during a Dry Run. Anyone have any ideas?

So you get a finished cut
Pop up says complete
Do you clear the popup by hitting enter?
Do you try the firecontrol keys by clicking the mouse?
And nothing happens?

I have not tried clearing it by hitting enter. I have used the mouse and touch screen. Both ways the messages clears and then nothing works.

Ok…I was trying to see if the message was clearing…
It is very strange that you get cuts and everything runs fine but freezes at the end of the whole process.
I am not sure what to do next…maybe one of the other members has an idea

Hitting “Enter” instead of clicking on it with the mouse didn’t help. However, it will let me click on the “refresh” button for the machine and it refreshed everything and everything worked from there. Next time I’m gonna try just hitting refresh on the THC and see if that has the same effect.


I have the same issue, have not refreshed but the CNC will not respond after cut completes. Buttons light up, but no response. I have closed Firecontrol and launched again to correct. I will try the refresh. Sounds like the machine stops communicating after completing the cut. I tried another laptop just to be sure with no change.

Langmuir, Any thoughts or ideas?

Thank You

I get the same issue. I upgraded my OG crossfire with THC. I even bought a faster laptop, thinking my laptop was not enough to run Firecontrol. Issue still there.

Same issue, was working fine, then it just decided to lock up after cutting. uninstalled and reloaded the program, but no luck fixing it.

are you using sheetcam to post process? someone else had this same issue and was using sheetcam but had a copy of a copy of the post processor and that was causing the issue.

I am running Sheetcam, but mine came straight from the source.

post a pic of the post processor screen. you should only have 1 that says firecontrol 1.6 or something to that effect. you might have a second copy that has (1) on the end. If that’s the one currently selected, then select the original one and try it.