DEAD IN THE WATER!rw cut 45 won't fire at all, manual or with the table

what I assumed was an issue caused by settings or something, has turned into a dead in the water scenario.
My cut 45 won’t fire. Nothing I do can get it to fire.
At first it was intermittent. So I ground to the workpiece always. Then it would randomly skip letters on a sign… now. It won’t fire at all… either by hand or with firecontrol. Nothing. Any ideas? I’m thinking a bad relay maybe??

check the fuse on the plasma cutter…it may blown…

@mechanic416…this man is the guru of plasma cutters here…

It is under warranty for 3 years contact the place you bought it from.


Would the fuse cause it to simply not fire?
I get the air, on and off as it should. Just no ignition … I dont remember seeing a fuse anywhere…

I suspect an internal issue and not a simple fuse problem since it’s powering up, air solenoid activating and torch not firing. Contact the supplier as George suggests and pursue the warranty.

1 Like

Air quality perhaps.

Stuck electrode if you get air and no fire.

1 Like

Razorweld 45 does not have a fuse. What torch do you have on the plasma cutter? There were 5 different torch’s used on the Razorweld 45.

I still think you should go the warranty route. But here are some things that can cause your issue.
As Tom said stuck electrode. More to the point would be a stuck or damaged electrode plunger. They may be new but the wrong or after market consumables will cause this. Are all the consumables installed, a missing or damaged swirl ring will cause this. A bad connection or wire in the torch. Air pressure to low or restricted some were. These are only a few things that can cause your no fire issue.


I’m not sure of the specific torch model. X45? I’ve only had the plasma cutter and table for about 3 months. I bought the entire setup Langmuir.
I am going to do the warranty, my gut tells me its a relay inside the cutter.
My air quality is great, IR 60 gal, 14.5 CFM, air cooler and 3 stage desicant dryer, plus inline air filter.
I pulled the torth apart and the plunger springs in and out smoothly and looks almost new.
I tried 3 different consumables, I have the hypotherm ones. And although not the exact ones you should use, I’ve had zero issues with them and they are readily available for me.

I really appreciate all the insight gents.
Still haven’t heard back from langmuir via email, and nobody answers the phone when I call. :roll_eyes:

Hypertherm consumables are considered after market as they were not made for that torch.

I agree. I only swapped them out to see if it helped… the original ones stopped working as well. Ive tried a few different aftermarket ones. As i havent ordered more from langmuir or razorweld. Be that as it may, this still seems like a internal to the machine problem. Cant see the hypertherm ones working then suddenly not working at all. … i pulled the torch all apart and found no issues. No damaged chuffed wires… ive heard people talk about a relay that stops working…other then the air solenoid when you depress the trigger, is there some way to test for voltage at the torch?? Ive already checked the both cables for continuity.

I also checked the plunger out and it looks brand new and moves freely…

The relay that most people are talking about is the relay in the Langmuir control box not the plasma cutter.

Ah, Ok.
Well I think I can rule that out as I can’t get it to fire even when I use the trigger. Still waiting on langmuir to email or call me back. Does razorweld do thier warrenty direct or do I have to go through langmuir as I bought the cutter from them? Anyone know?

Have you unhooked the plasma cutter completely from the Langmuir controller and tried the torch?

I stand corrected… these aren’t the hypertherm consumables. Not sure where I got these ones from. I believe i ordered extra when I bought the table.
They all carry the same pn on them and are identical.
Man this is frustrating. Already lost a customer today. Mechanic416 whats your opinion on the cut 45 vs the HF titanium cutter?? I could grab one of those maybe faster then waiting for the warranty. Especially since langmuirs site says its 6-8 weeks backorder for the plasma cutter. I’m imaging a loooong wait for the warranty…

yes. Completely unhooked. Still no go. Air comes on/off. No fire.

Why don’t you call me.

This looks to me like they didn’t do the service bulletin. Unfortunately, I would probably have to order a register to do it myself. Probably going to be down for a few weeks. This blows.

Actually. I have that wrong. As the C101 register IS completely removed. So. Still sucks lol