Can’t get Razorweld to fire

Hi all,
Sorry if this is a repeat question or if I’m just dumb. I’ve just finished setting up our first gen Crossfire. Running the Razorweld 45. CAD was done in Inkspace, CAM was done in Sheetcam. I load the GCode into Mach3 and hit start and everything works great except the torch doesn’t fire. Hitting the fire button in Mach 3 doesn’t fire it. Hitting F5 doesn’t fire it. Only thing that fires it is if I hit the trigger manually. I can’t find any videos that show wiring the torch fire cable inside the machine. So I can’t wire in Bag#14. It came with a wire that plugs into one of the two ports on the front of the Plasma. But neither one makes it fire. I have FireControl-v1.5(Edited) selected in sheetcam. NEED HELP.

Hi @KerbAppeal,

Can you unplug you torch firing cable from the CNC box and then using a multi-meter check the continuity across the center pin of the plug and the inside shell. There should be continuity across these pins when you manually fire the torch in Mach3 and no continuity when the torch is off.

If that works, turn your plasma cutter on and use a paper clip to jump the center pin of the torch filing cable to the outside shell of the cable. This will cause the torch to fire as if the trigger was pulled. If this works your cable and torch firing port are working as expected.

1 Like

I got it to fire. But now it doesn’t completely shut off during the transitions. Not all of them, just some. So it leaves a scar along the path it takes to get to the next cut. I’m guessing that’s a setting in my GCode? Any suggestions?

Your cutter is likely set to 4T- you’ll need it set to 2T. There is a button on the front to do that.


Thank you Daniel for all the help.