Banging my head… (SOLVED)

Ok so I’ve got the crossfire pro package with THC Everything plug and play. I’ve got the latest version of Firecontrol and I’ve downloaded sheetcam. Trying to do my first cut here. I drew just a simple letter A in Inkscape and save it. I open it up in sheetcam and set up my cut paths. I set up my machine mode in jet cutting but somehow I’m missing something I think in setting up sheetcam settings. I’ve watched some utube videos but I’m still a bit lost. I run the post processor and create the gcode then save it. It saves as a tap file but I keep getting “No program speed found” pops up on my Firecontrol screen. Any feedback guys? Thanks

Welcome to the forums…

so did you download the proper post processor from Langmuir for sheetcam?

you ned that installed to postprocess for firecontrol…

then is it the free trial version of sheetcam you are using…the free trial version is very limited…

1 Like

Thanks for the response. Yes I’ve downloaded the correct version but I simply downloaded the sheetcam version on the website as you’ve shown. There’s a better version? Thanks

You shouldn’t need to download anything. The current version of Sheetcam has the Firecontrol Post Processor in the library. Here is a short video on how to select the post processor. Loom | Free Screen & Video Recording Software | Loom

The other reason for “no program speed found”, is that you didn’t actually create a Jet Cutting operation before post processing. Sheetcam will not warn you that you didn’t create an operation, it will post process anything into a .tap file when you hit that button. Here is a short video walkthrough of the process, the simulation at the end is not necessary. Loom | Free Screen & Video Recording Software | Loom


Thank u. I will watch it. Do appreciate

So sheetcam isn’t warning me it’s coming up on Firecontrol when I try to load the file that I saved.

Right. What I was saying is, that Sheetcam won’t tell you when you’ve done something wrong. You won’t find out until you try to run the file.

If there is no program speed, you either didn’t create a jet cutting operation or you didn’t select or properly set up your tool.

That’s what I’m saying I’m missing something on the set up in sheetcam. I try to run the simulation and I’m getting that message in SC. I’m not sure how to correct it.

Did you create a tool to cut with? The program speed comes from the tools that you create. On the left side of the screen, in the middle, is the list of tools that you have created.

yes I created a tool in the jet mode and I call it plasma2 It shows in the left side under tools.

In machine options there is a box to the far right that says save/load Im not sure what to put here? If anything I click it and it goes to my documents folder

OK. Next thing, after importing your drawing, is to create a jet cutting operation by clicking on the top Icon on the left of the operations box. That brings up the Jet Cutting operation screen and you select “outside offset”, then select your sketch and your tool. Check “reverse cut direction”, fill in the lead-in/lead-out fields and hit OK. This should turn all of the lines in the sketch to Green and show the lead-in/outs and the rapid paths. At that point, you can hit the post process button.

1 Like

so I import a drawing I brought up the box from operations on the left of the screen I selected the outside offset and click reversre cut direction I didnt see where I select sketch and tool. I see them in the boxes on the left

I fill in the leadin/leadout and hit ok but my lines dont change to green and the simulation wont work

The sketch is selected in the “layer” field. The tool is in the drop down menu for “tool”

1 Like

ok ya I’ve got that. I selected my sketch which was layer 1 and my tool. I hit ok and Im just looking at my drawing… No green lines… sorry im such a rookie

Can you post a screen shot of your Sheetcam screen? Maybe I can see what’s missing.

You will not see toolpaths unless this button is turned on.

You have 2 “outside offset” jet cutting operations in the operations box. You can delete unwanted operations by clicking on them and hitting the delete button on your keyboard. This is not the cause of your issues, though.

When you import a drawing, Sheetcam will assign the proper offsets to the lines, provided the drawing doesn’t have problems. The lines will be Red for outside offset, Yellow for inside offset and White for open lines. This is why you can simply select “outside offset” in your operation and Sheetcam will assign the correct offsets based on the color of the lines at import. There is usually no need to create separate operations for Inside and Outside offset.

When you select your drawing(layer) in the operation, the whole drawing should turn white. In that screenshot, the drawing does not look like it has been selected for that operation.

I noticed that you have the “use lead ins on open paths” selected. You should turn that off, or you will get a lead in that comes in from the side of any open paths. For example, if you had a straight line cut in your drawing, the lead in will make an “L” shaped cut instead of a straight line.


I did my first cut over the weekend. Thanks for the help. I do appreciate it. I couldn’t respond because of the default settings on this forum having to wait for a day after so many posts. Anyway not having my sheetcam settings correct was my problem. Cheers

1 Like