Ball Bearing Movement

I am done assembling the CrossFire PRO (CFP), and I have downloaded FireControl and have trial-and-errored a few things and finally gotten the CFP to move along all of its axes (X, Y, and Z); however, I am having some push back from the Y Axis Ball Bearings, and I am wondering how I can adjust the ball bearings to either loosen up one or tighten the others. All the movement is being pushed onto one ball bearing, while the others don’t even rotate.

Anothre question I have which relates more to the Software side of the CFP is how I download Cut Documents into the FireControl software. I am working with a DXF file, so do I need to convert that to a G-code file, and if so, how do I do that?

So I’ve been reading through some of people’s suggestions, and I think what the problem may actually be is that the 2 Y-Axis motors are firing at different times - basically, the one on the right is a little bit slower to move than the one on the left, so as a result, once the torch gets towards the back of the machine, it starts to choke up and have a lot of resistance to movement. The Y Axis motor on the left reaches the back of the machine before the one on the left, but the reach the front of the machine at the same time, so something is going on towards the back of the machine that is causing a sort of lag to the right side of the Y Axis motor.

Just to be clear, the stepper motors are always commanded to rotate at the EXACT same time. I have not yet seen a situation where one motor was actually rotating before the other despite what the user may believe is happening.

To best assist you it would be great if you can post a video showing what’s going on.

Quick question- are your couplers tight (verified with sharpie match marks between coupler, motor shaft, and lead screw? And are your lead nut screw tight?

1 Like

fire control reads G code you’ll have to post out of 360 first

maybe one side of Y axis screw doesn’t have preload?

I will send you a video of what’s happening.

Where on the machine are the couplers and lead nut screw? Are they by the Y Axis Motors?

Also, I have uploaded my design into CAM in Fusion 360, and I have followed all the videos that go step-by-step on how to make the file fit the requirements for running it in FireControl, but when I finalize it and go to Setup, my path is all messed up. The torch only makes one cut of the multiple ones I need it to for the piece I have designed.

Again (sorry for all the questions by the way, I am a 17-year-old intern who is trying to wrap his head around the crazy CNC Plasma Cutter his boss wants him to figure out hahaha), is there an easier way to upload a DXF file and turn it into a Gcode file that will FireControl is compatible with? I have gone through this whole process and I feel like there has just got to be an easier way to do this, and I just don’t know how. My boss has designed the piece already in CAM as a DXF file because that’s the platform we use here, so I really don’t want to have to go through this process every time I want to make a cut.

Thank you all for your help! You’re helping me help my boss, and I appreciate that.

On the end of each lead screw is a coupler that looks like a small (1") black cylinder. The lead screw goes in one end and the motor shaft is in the other end. There are small allen head set screws in recesses in the coupler. These are used to lick the coupler onto both the lead screw & the motor shaft. Then when the motor turns, the screw turns. If they aren’t really tightened down hard then the motor or lead screw can slip. If you take the setscrew out you can see where the point will land on the lead screw - turn the lead screw until you have the hole for the set screw lined up with the space in the screw threads or a flat spot and then tighten the set screw. There are a couple in each end.

The lead nut screw is under the rail and has a white nylon flare surrounded by a black plastic cylinder. The lead screw goes right through it. When the screw turns the head or rail moves back & forth. The lead screw is attached to a small L shaped bracket with 4 small nuts & bolts. Make sure they’re all right and the screw goes roughly through the center of the hole in the bracket and the white lead screw nut on the other side.

Video of Y-Axis Movement

Basically, towards the back of the machine it locks up and won’t move smoothly.

video not available

did you load the file for fusion from langmuir so it writes the code in the proper format for Firecontrol?

sheetcam is a purchased software that is real easy to use and takes dxf or svg and with the patch from Langmuir it writes a tap file for fire control

I loaded the file in Fusion360 and followed all the steps to turn it into Gcode… everything has worked so far except the fact that the toolpath doesn’t recognize all the cuts I want it to make.

That often happens when the cutout piece is too small for the lead-in/lead-out settings. Just define another toolpath (in the same Setup) with smaller values or different angles. There may be some you’ll need to define a toolpath that won’t allow any lead-in and for those you’ll just get a divot. Just remember to generate the Setup & not the toolpaths. That way all of your toolpaths are in the same GCode file.

With Sheetcam for those paths I’ll define the cut with a shorter pierce delay and some overrun so it’s moving when it pierces and then when it comes around to complete the cut it goes past the end and overlaps the start to cut the little bit that wasn’t cutting when the head started moving. I never tried that when I was still using Fusion so don’t know if there’s a way to do that easily.

Scanned Documents.pdf (505.8 KB)

Here is a photo of 2 wires that I do not know where they are supposed to be?

They are connected to the smaller box that velcroes onto the RazorCut45.

here is what you need to read…