All put together, first cut file ready, only got one pierce

I loved putting together the XR, it was an awesome experience, more challenging and time-consuming than I expected but the table works great. I loaded up my first test file, filled the table, and hit cut. I got one pierce and then nothing. I’ve taken all the torch and THC stuff apart and put it all back together again. Everything is wired right, good ground, great air, Razor weld operating manual has the THC voltage and the Torch fire port reversed from the Langmuir instructions so I tried that. . All I got was a really high THC voltage. Because I just have the machine torch I can’t test it by hand. I’m stumped and frustrated.

I sent an email to both Langmuir and Razorweld. Any other suggestions?

Updates, Jumping the torch fire cable got the torch to fire! So I’ve narrowed down the challenge to the XR control box. I disconnected and reconnected the USB cables and tried it again. no joy. The relay isn’t switching in the control box.

1 Like

I just spoke with Cameron in LS support, I am so impressed with these people! I’m hopeful that we have some additional direction soon.

1 Like

Resolution is on the way, we should know more in the next couple of days. Stay tuned!

Update - The machine is FIXED and firing as it should! Shout out to Cameron for the awesome help.

2 Likes

What was your fix? Just got mine all hooked up and no bueno. Torch fires when pins are jumped, but no continuity on the control box pins when manually firing torch and no relay click.