CrossFire ®   Troubleshooting


Topic Replies Activity
About the Troubleshooting category 1 July 20, 2018
Wireless USB mouse 2 October 17, 2020
Y Axis Leadscrew Issue/Binding Near Max Travel - SOLVED 39 October 16, 2020
Cuts larger than file 7 October 13, 2020
Razorweld stoped firing 6 October 10, 2020
Can’t get Razorweld to fire 5 October 6, 2020
Computor not recognizing fire control 4 October 4, 2020
FireControl 20.4 and CrossFire LS22 - No Connection 2 October 3, 2020
Plasma cutter freezes when fired up 1 September 28, 2020
XL lead screw vibration, set screws coming loose 4 September 26, 2020
CrossFire set assistance 3 September 20, 2020
Random not cutting all the way through 56 September 15, 2020
New CrossFire, No Connections in FireControl- Solved 9 September 9, 2020
Some designs simply doesnt cut. It almost appears that Mach3 stops midway G Code 2 August 27, 2020
Today Is A Good Day 7 August 22, 2020
Plasma cutter will not turn on when trying to run a cut 4 August 21, 2020
Hey everyone, it's been awhile - RNR motion card not found 4 August 19, 2020
Anyone getting hot spots on the bottom of their water table? 16 August 18, 2020
Mach3 Intermittent Lockup 1 August 18, 2020
Torch will not fire in mach 3 but will pulling trigger 3 August 17, 2020
Strange cutting error 3 August 17, 2020
Probably an easy fix! 3 August 3, 2020
Design not cutting correctly 4 July 30, 2020
Worn y axis bearings 1 July 28, 2020
Razorweld 45 Torch Wiring Trigger Issues 13 July 24, 2020
The motion command has an invalid target. G2,G3, and G38.2 13 July 7, 2020
Stepper motors stopping 9 June 30, 2020
Y Axis Travel Error 3 June 26, 2020
Intermittent firing 1 June 23, 2020
Cutting seems a little sloppy 4 June 21, 2020