CrossFire ®   Assembly


Topic Replies Activity
About the Assembly category 1 July 20, 2018
Lead nuts in bad shape 8 July 21, 2019
X axis nut bracket not formed correctly 1 June 14, 2019
Preinstalled bracket backwards? 4 June 11, 2019
Bearing doesn’t fit into bracket 4 June 5, 2019
Leg Hole Alignment Issues 16 May 29, 2019
Leg alignment issues also 3 May 29, 2019
Lead screw rubbing on Lead Screw mounting flange 7 May 13, 2019
Just got my table in. :) 3 May 12, 2019
Just assembled new table - prblems with gantry 8 April 27, 2019
Gantry at an angle? 5 April 26, 2019
Installing a Miller plasma cutter 1 April 25, 2019
Almost ready to do an initial start up run HELP 2 April 25, 2019
Alignment Issues after assembly 6 April 20, 2019
Problem with casters falling out everytime i move my table 2 April 20, 2019
Can't get water table level 4 April 19, 2019
Just assembled my new table today 2 April 14, 2019
Slat holder issue? 4 March 3, 2019
Upper rail tube out of spec? 8 February 17, 2019
Missing nuts on x-axis / gantry bolts 2 February 11, 2019
X axis stepper motor hissssss 9 February 10, 2019
Stanchion plate upper rail alignment issue 8 February 3, 2019
Water Table Drain Plug Leaks 5 February 2, 2019
Water table slat heights issues 27 January 23, 2019
Powder Coating Stainless W/T? 5 January 20, 2019
Important for eu users 1 January 18, 2019
Crossfire Electronics Box 3 questions 4 January 7, 2019
220V Power Cord? 3 January 6, 2019
Bulkhead Tank Fitting 5 January 5, 2019
Gantry Bearings 6 December 29, 2018