CrossFire ® PRO   Troubleshooting


Topic Replies Activity
About the Troubleshooting category 5 June 10, 2020
Divots At Beginning Of Cut 46 October 27, 2020
Measuring plasma arc voltage / THC on oscilloscope? 9 October 24, 2020
Getting frustrated 23 October 23, 2020
X-Axis Movement 7 October 15, 2020
Losing Arc Voltage - SOLVED 37 October 10, 2020
Z axis question 4 October 5, 2020
Torch fires and sometimes it doesent 19 October 1, 2020
Can't upload a file to Fire Control 16 September 21, 2020
Thin material issues? 5 September 15, 2020
Problem with torch not refiring between cuts 20 September 12, 2020
Jagged/wavy edges 20 September 7, 2020
Wrong Torch ON/OFF port installed on Pro Electronics box? 2 September 3, 2020
Machine not jogging, initial startup - SOLVED 3 August 17, 2020
X Axis play/lash and resistance issues 5 August 15, 2020
Binding when changing directions Y axis - Solved 17 August 8, 2020
X axis fails to move 7 August 7, 2020
THC issues Crossfire Pro 21 July 23, 2020
Cross Fire Pro not piercing 25 July 13, 2020
Cuts not Completing 33 July 11, 2020
Torch will not fire in program 10 July 4, 2020
Pro Break in Program 4 June 9, 2020
Miller 625 Extreme not re-firing after move 2 May 18, 2020
Firmware update wrong port 3 May 18, 2020
IHS fail. The torch is not in the expected initial state before starting IHS cycle 9 May 6, 2020
Gcode problem with THC 15 April 29, 2020
Torch stops moving but keeps cutting, software freezes 2 April 24, 2020
CrossFire Pro torch not firing new setup - SOLVED 7 April 22, 2020
USB keeps connecting/ disconnecting 10 March 31, 2020